Jump to content


Photo
- - - - -

Unable to Travel in World Adventures


  • This topic is locked This topic is locked
14 replies to this topic

#1 pcdoctor

    Team Mascot


  • 86 posts

Posted 02 January 2012 - 12:48 AM

Today I tried to travel to a different country in Sims 3 and what happened was I was able to book the vacation, leave my house, but when it got to the place I wanted to go to, my sims would not load at all. The game would be playing live, but they just wouldn't show up. I also had to Ctrl Alt Delete to get out of the game too and shut it down that way. I have all EP's and SP's to this date. Why's it doing this?

#2 Stellagirl

    Stargazin' Hippy


  • 76 posts

Posted 03 January 2012 - 09:50 AM

I am also having this issue. I have no mods. I re-installed all EP's up to Generations and have patched them all (don't have the most current as this is for Pets which I dont have) as I was having issues before with WA.
When I re-installed the game I tested if I could travel and it worked. I left it then as my sims were not ready for travel. Now, I am ready for them to travel and this exact same thing happens.
I think I read somewhere that it might have something to do with story progression but I'm not sure.

Will be watching this post to see if we can both get answers :)
Always,
Stella XOXO

Wedding Date - 24th October, 2009. What a magical day XOXOXO
Baby Grace Ivy born 16th October 2010

#3 KSkywalker

    Trashcan Kicker


  • 471 posts
  • LocationMassachusetts

Posted 04 January 2012 - 10:07 PM

I don't know why this happens, it is a pain, no doubt about it. To save my sanity, I always save the game before I make the call to travel. If they don't make it to their destination, my Sims are still safe "at home". Save before you travel home as well, and preferably before that one hour warning!

You should always keep your game patched and up to date. Even though it may be called "The Pets Patch" it patches all the games up to that point, and you will need it to install Custom Content.
Proud Auntie of Alyssa, Nathan, Brian & Kaylin

#4 Stellagirl

    Stargazin' Hippy


  • 76 posts

Posted 05 January 2012 - 12:53 AM

Thanks for the reply KSkywalker. I have since patched my game with the Pets patch which hasn't fixed my problem. I have always saved my game at the end of each session and before doing anything like travel by 'saving as' and renaming the save by number. I have done this since first reinstalling but I haven't kept all of the older saves so I'm not sure when this error has happened.

Is there any way to actually fix it now that it has happend? I have just given up on travelling as it NEVER works anymore. I have invested a lot of time in my current family and really don't want to have to re-install again and loose everything. If I had to do that again, I think I would just give up on TS3 for now and go back to TS2 until that have fixed any issues.

PCDoctor, I hope you don't feel like I have hijacked your thread. Didn't think it right to start a new thread about the exact same thing and, hopefully, we can both get an answer to this problem.
Always,
Stella XOXO

Wedding Date - 24th October, 2009. What a magical day XOXOXO
Baby Grace Ivy born 16th October 2010

#5 daisylee

    horsing about in Appaloosa


  • 7,370 posts

Posted 05 January 2012 - 04:41 AM

Rename your game and let the game generate a clean one and try and see what happens. The only time I had problems like this were due I am pretty sure to a bad CC item. If you can travel with no problem with no CC, then a CC item may be the cause of the problem.

Whenever there is a problem it is best to test in a clean game as that can tell you a lot.

#6 Stellagirl

    Stargazin' Hippy


  • 76 posts

Posted 05 January 2012 - 09:47 AM

Rename your game and let the game generate a clean one and try and see what happens. The only time I had problems like this were due I am pretty sure to a bad CC item. If you can travel with no problem with no CC, then a CC item may be the cause of the problem.

Whenever there is a problem it is best to test in a clean game as that can tell you a lot.


Thanks Daisylee. I'll give this a go and see what happens. Can you please just clarify what you mean by 'renaming' my game as I thought thats what I was doing already by numbering my saved games (eg, Ashton 1, Ashton 2 etc). Or perhaps I need to rename it something completely different?? Not a full bottle on how TS3 works in the back ground. Also, do I remove my downloads folder before restarting and renaming my game. What will happen to the CC in game?

Thanks again.
Always,
Stella XOXO

Wedding Date - 24th October, 2009. What a magical day XOXOXO
Baby Grace Ivy born 16th October 2010

#7 daisylee

    horsing about in Appaloosa


  • 7,370 posts

Posted 05 January 2012 - 06:39 PM

You are doing save as saves it sounds like. In your docs rename your game to something like My The Sims 3 and then start the game. It will generate a new clean game. Send a sim abroad in that game and see what happens. After you are done testing and when you want to play your game again, delete the new one and rename your game back to The SIms 3 to play it again.

#8 Stellagirl

    Stargazin' Hippy


  • 76 posts

Posted 06 January 2012 - 07:22 AM

Thanks Daisylee. I did what you suggested and tried travelling in a clean game with no mods or CC and was able to travel just fine. I then added in a copy of my downloads folder which just has object and hair CC (no mods) and again was able to travel just fine.

So, I then deleted the clean game and renamed my game back to The Sims 3 and deleted my mods folder but left my downloads folder. As far as I can see these two versions of the game should now look tha same.......but my game is still not working. I am unable to travel :( Any other suggestions?

If not, do you know if I can maybe upload my family nd house to TSR and then download them again into a clean game without bringing the problem with me?? Long shot, I think, but worth asking as I have invested so much time into my family and really don't want to loose them
Always,
Stella XOXO

Wedding Date - 24th October, 2009. What a magical day XOXOXO
Baby Grace Ivy born 16th October 2010

#9 Stellagirl

    Stargazin' Hippy


  • 76 posts

Posted 06 January 2012 - 07:42 AM

Just to update, have just removed my downloads folder from my documents and uninstalled all CC through the launcher and still has not made any difference to my game.
Always,
Stella XOXO

Wedding Date - 24th October, 2009. What a magical day XOXOXO
Baby Grace Ivy born 16th October 2010

#10 ziggy28

    Tragic Clown Catcher


  • 388 posts

Posted 07 January 2012 - 05:50 PM

If you have had mods in your game and not cleared the caches files the game may think you still have them installed you need to do this :-


Mydocuments/Electronic Arts/The sims 3 folder and in there you will find 4 loose cache files CASPartCache, compositorCache, scriptCache and simCompositorCache delete these files

I hope this helps.

You should also look in your saves folder for any .bad saves and delete them, if you have a .backup for the current saved game you are playing, try using the .backup file instead...

#11 Stellagirl

    Stargazin' Hippy


  • 76 posts

Posted 08 January 2012 - 10:58 AM

Thanks Ziggy28. Have done what you suggested and my game is still borked. Are you able to advise regarding exporting my house and family out of my game without taking the problem with me?? I'm thinking this might be my only option, short of just not travelling, but this seems like such a waste when I have the expansion pack.
Always,
Stella XOXO

Wedding Date - 24th October, 2009. What a magical day XOXOXO
Baby Grace Ivy born 16th October 2010

#12 Degera

    Facebook & Submission Support


  • 1,351 posts
  • LocationNorth Carolina

Posted 09 January 2012 - 05:15 AM

Hi Stella! So sorry to hear you are having trouble. I don't know if doing this will carry the problem to a new game, but let's try...

Part 1 - Place the family you want to save onto a new, empty lot, any lot but NOT a house, then go into Edit Town mode and select that lot. It should give you an option to 'Share'. It doesn't matter what you name the file. Once you get the confirmation message that the file has been uploaded, go back to your main menu and click the 'Open Launcher' option. If your launcher is not already open, this will minimize your game and bring you straight to your launcher screen where you should see a shiny new Sims3pack file. Put a check into the box next to the pack file and click the 'Show File' button at the bottom of the launcher. This should open the folder where the pack file was saved. Now grab that file with your mouse and drag it to your desktop. Close your launcher.

Part 2 - Close the game completely, and re-name your Sims 3 folder, as you've done before. Now, before you start the game, right click on the Sims3pack on your desktop and choose Open. This will install your family into your new game and bring up the launcher. Enter the game and send your family on a test trip. Hopefully everything will go as planned.

If this works, you can go back and follow these same steps to get the house by itself. I suspect if you try and export the house and the family together, you're going to run into the same problems as before.

#13 Stellagirl

    Stargazin' Hippy


  • 76 posts

Posted 10 January 2012 - 12:23 PM

Degera, you are a STAR!! I've done what you suggested and so far this has fixed my problem and I'm able to travel again :D

I would really like to thank everyone here who has helped me with this problem. You have all been so helpful. It means alot to me and others knowing there are people out there willing to help us out when things so wrong :wub:
Always,
Stella XOXO

Wedding Date - 24th October, 2009. What a magical day XOXOXO
Baby Grace Ivy born 16th October 2010

#14 Degera

    Facebook & Submission Support


  • 1,351 posts
  • LocationNorth Carolina

Posted 10 January 2012 - 11:46 PM

I am so glad it worked, and hopefully you won't have this problem again! :)

#15 rose-maman

    Adam's Girl


  • 4,362 posts

Posted 17 January 2012 - 01:27 AM

Cool!..
I am happy your sims can now travel again..see, I have the very same problem but tell me..just to be sure..
You simple move your beloved sim family into a clean new World, and now all is well..?
What happened to your CC and mods ?

I could not care less about the relationship my sim family would have in Riverview right now, and so moving them into a new one would be fine with me but, playing without my cc and mods well..neither my sims and their house would be the same and enjoyable.
I wonder if this same way, would solve my problem, too! :)

♪♫•*¨*•.¸¸❤¸¸.•*¨*•♫♪ Adam & Rosie ♪♫•*¨*•.¸¸❤¸¸.•*¨*•♫♪

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users