Jump to content


Photo
- - - - -

Cant register my game


  • This topic is locked This topic is locked
7 replies to this topic

#1 suzukisonya1975

    Junior Member


  • 1 posts

Posted 27 January 2013 - 03:20 PM

i recently purchase a sealed copy of Sims 3 and installed it on my computer. However i cannot access simpoints features as every time i have tried to register my game it says the code isnt recognized??? whats up with that??? Have i been sold a dodgy Sims3??? Any help please??

#2 InaMac69

    Junior Member


  • 8 posts

Posted 01 February 2013 - 12:05 AM

I know this may seem like a silly question but have you typed in the right code? Using CAP lock on. Sometimes B and 8 look very similar and S and 5 I often make these mistakes. :)
visit my Mini Site Here

#3 Angel-chan

    Newbie


  • 8 posts
  • LocationMars, Pennsylvania

Posted 24 February 2013 - 07:05 AM

I agree.. I can't regiter my game either saying my SN is wrong.. EA page is not working either... :angry: :unsure: :( :wub:

Edited by frisbud, 24 February 2013 - 03:03 PM.
Removing color from post. Please review our Forum Rules. Thank you.

Angel-chan

#4 dudie2011

    Junior Member


  • 3 posts

Posted 24 February 2013 - 08:11 AM

Same problem - wot's up with that?

#5 frisbud

    La Femme Samantha


  • 1,784 posts
  • LocationI'm a Barbie girl, in a Barbie world

Posted 24 February 2013 - 03:07 PM

Are you entering the code in the right place on the Sims3 site? You need to go to My Page, then in the My Games box click on the Register a Game link.
TSR Sims 1 Featured Artist & Sims 3 Select Artist -- Visit my Mini-site and see what I'm working on in My Blog
Sam's Sims Yahoo Group -- Added March 26, 2009 -- Unleashed Community Lot 61 Farmers Market

#6 Angel-chan

    Newbie


  • 8 posts
  • LocationMars, Pennsylvania

Posted 26 February 2013 - 05:44 PM

Did that still the same message..
Angel-chan

#7 sim_man123

    Simmer


  • 2,734 posts
  • LocationFlorida

Posted 26 February 2013 - 08:08 PM

That's odd that multiple people are having the problem at the same time - if the EA page is down, I'm guessing that perhaps whatever part of their server verifies serials could have been down as well. Unfortunately, you will have to get in contact with EA to get this kind of thing sorted out.

Kris

mqpe.png


#8 Eluna

    Team Mascot


  • 68 posts

Posted 02 March 2013 - 10:30 AM

I have the same problem and when I tried to install terrain maker it just said- can't find game data even if I have the game itself installed and it is working.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users