Jump to content

- - - - -



  • Please log in to reply
2 replies to this topic

#1 biel-23


  • 1 posts

Posted 19 May 2017 - 12:27 AM

Heey guys..Im making some new furniture BUT i having some GIANT PROBLEMS .. i import the mesh files and textures (in dds cuz tsw sucks sometime)and everything went fine... i import to the game as package file using Sims3pack Multi Installer, I went to the game and what I saw made me very frustrated (I tried to redo everything 3 times)...THE MODAF*CKJAHUSHUAHU TABLE HAS NO TEXTURE AND SHOWS UP FULL BLACK ....So I'm almost lying on my bed, turning aside and crying all night. WHAT CAN I DO ? 

Help Me Pleeease.

#2 sim_man123


  • 4,610 posts
  • LocationFlorida

Posted 20 May 2017 - 04:18 PM

You made your textures properly - including an RGB mask with the correlating patterns being set for the textures you want the table to have? The overlay and any stencils are not black, are they? Did you change any settings in the shader, or the type of shader?

Also, what meshing program are you using? The normals on the mesh could be reversed.

There are several things that could be wrong, if you want to either post or PM me a copy of the file, I'll take a look at it and see if I can find anything  :)

  • biel-23 likes this

#3 sim_man123


  • 4,610 posts
  • LocationFlorida

Posted 21 May 2017 - 02:51 PM

(I'm posting back here instead of in your PM so that other people can find and read this in case they have similar issues)

The first thing I would say, is do NOT make objects with diffuse-map style permanent texture. That is simply not how the game was designed to work. You'll only be causing more headache and confusion for yourself in trying to constantly work around the RGB mask and patterns. That recolorability was one of the key selling points of TS3 - it's how the game was designed to work, and you need to learn to work with it. Especially if you ever plan on sharing your creations. If you want permanent diffuse-style textures, TS2 and TS4 work that way. Not TS3.  ;)

As for the actual problem, I would guess it probably happened from when you reversed the vertex order in Milkshape. If I understood that correctly, you have two copies of the mesh, correct, one that is reversed? Polygons are single-sided and will be invisible from one side - this is normal. For a solid object, it shouldn't be a problem, as the invisible side is "inside." Right click on your mesh in the 3D view in Milkshape and uncheck "draw backfaces" to get an accurate idea of which side will be invisible and which side will be solid, then you can reverse the vertex order as needed. (Duplicating the entire mesh just doubles the poly count and how hard the computer has to work to display the mesh.) 


Is the mesh actually black in Milkshape as well? You may find that going to Face > Smooth All will fix that, but it can also mess up your shading and smoothing groups. (There is a bit of info on how to use smoothing groups here)

Also tagged with one or more of these keywords: PC

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users