Jump to content


Photo
- - - - -

[sims3/TSRW/Blender]Create clothes with Blender


  • Please log in to reply
5 replies to this topic

#1 Goby03

    Newbie


  • 4 posts

Posted 29 July 2017 - 02:50 PM

Hello,

I have export a dress mesh with TSRW into .obj file. I edited it with Blender. At this point, all worked fine. But when I import the new mesh to TSRW, it didn't work. The tool didn't import the new mesh, I have an error message.

I made a lot of test with a friend, and we arrived at the conclusion that the problem is with Blender.

We tried :

* with the most recent version of Blender and the 2.6,

* with the last version of TSRW and an old version,

* to import a mesh into Blender and export it without edited it, but it didn't work.

* to rename the group "group 0" and "group 1" with and without this script : https://wiki.blender...name_Datablocks

 

 

Could you help me ? If it's possible, I don't want to use MilkShape3D.

 

Goby03



#2 sim_man123

    Simmer


  • 4,547 posts
  • LocationFlorida

Posted 30 July 2017 - 04:57 AM

First off, you can not use .obj for animated meshes, such as clothing or body parts. The .obj format does not have support for bones, so even if you could import the mesh back into Workshop, your clothing would essentially turn the sim wearing it into a statue. 

 

You need to use the plug-ins that come with Workshop to import and export .WSO to and from Blender. :) They can be found in C:\Program Files (x86)\The Sims Resource\TSR Workshop\Extras\Blender 2.74



#3 Goby03

    Newbie


  • 4 posts

Posted 30 July 2017 - 09:07 AM

Thank you very much ! :D

 

I installed the plug-ins but I only have the option to export and not to import. It's normal ?



#4 sim_man123

    Simmer


  • 4,547 posts
  • LocationFlorida

Posted 30 July 2017 - 03:20 PM

What version of Blender are you using? The plug-ins were specifically designed for 2.74, which is going to be an older version now with how often Blender is updated. Using it in a newer version may or may not work - or may not even show up.  :ph34r:



#5 Goby03

    Newbie


  • 4 posts

Posted 30 July 2017 - 04:05 PM

I know, I use the 2.74. But it don't work.



#6 Goby03

    Newbie


  • 4 posts

Posted 31 July 2017 - 03:22 PM

I reinstall Blender and nonw the plugin works ! :D

I tried to use it and I have a few questions :

* Why when I import my new mesh in wso I have an error ?

Spoiler

* How could I generate new morh to match with my mesh ?






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users